What's New in Impact / Enterprise 2019

Phil Spooner/Matt Hewitt

Document version: 1.0

This document contains details on the new features in Impact. This document applies to only the specified version of Impact.
## Contents

**Overview** ........................................................................................................................................ 5

**2D** .................................................................................................................................................. 6

- Dimension Tools ............................................................................................................................... 6

- General Drafting and Editing .............................................................................................................. 7

- Arrow key/cursor key nudges ............................................................................................................. 7

- New “To Layers” Tool .......................................................................................................................... 11

- New Layer “Quick Duplicate” Tool ..................................................................................................... 12

- Entity Highlighter Improvements* ...................................................................................................... 14

- New “Snap Cursors” Indicators ......................................................................................................... 16

- Palettes* .......................................................................................................................................... 17

**General** .......................................................................................................................................... 19

- Multi-page PDF Export* ...................................................................................................................... 19

- PDF Export to Respect Drawing Order (for better CutCrease export support)* ............................... 23

- Multi-Face Export* ............................................................................................................................ 25

- PDF Library Update .......................................................................................................................... 25

- DWG Library Update ........................................................................................................................ 25

- Support for DDES3 (CGATS/SC6/WG3) IT8.6 Revision Import ...................................................... 25

- Drag and drop from Outlook (or file locations) .................................................................................. 26

- Licensing/Nalpeiron V10* .................................................................................................................. 28

- Licensing/Dongleless Licence Server* ............................................................................................... 30

- Script Security Modifications* ......................................................................................................... 30

- Parametrics & Standards* .................................................................................................................. 31

- Memory Handling Improvements - Large-Address Aware (LAA) .................................................... 32

- Document Relationships for Symbols and Templates* ....................................................................... 32

**Manufacturing** ............................................................................................................................... 33

- Stripper Tool Performance Improvements ....................................................................................... 33

- Plotter Optimisation* .......................................................................................................................... 33

- Symbol Position Reference When Plotting* ......................................................................................... 34

- Automatic Creation of Symbol Patterns and Alternative Symbols ................................................ 35

- Blanker Frame Symbols Ordering* .................................................................................................... 35

- Rotary Dieboard Workflow Improvements ........................................................................................ 36

- Diemaking Auto Tasks and Value Mappings* ..................................................................................... 37

**User Interface** ................................................................................................................................ 38

- Screentips for Enhanced Project Previews * ...................................................................................... 38

---

* These features are marked with an asterisk (*) to indicate they are new or updated in this version.
Enhanced ‘Open Project’ dialog, including custom field lookup ........................................ 40
Icons for Visibility Toggles ............................................................................................. 41
Database .......................................................................................................................... 42
    Many-to-many* ............................................................................................................. 42
    Database Structure (DBS) ........................................................................................ 43
Non-enforced Null Changes* .......................................................................................... 44
Archived or Active Items for Dynamic Lookups* .......................................................... 44
Table Display Names/Prompts ....................................................................................... 44
Translatable Table and Column Prompts* ..................................................................... 45
Layer List Sorting .......................................................................................................... 45
Improved Customer Selector and Customer Group handling* ....................................... 46
Bill of Materials (BOM)* ............................................................................................... 48
New Project ‘Open Copy’ Action ..................................................................................... 48
Enhanced Database Windows* ....................................................................................... 48
Control Type Icons ......................................................................................................... 48
    New Control Types* ................................................................................................. 49
    Picture Control* ....................................................................................................... 49
    Check Listbox* ........................................................................................................ 50
    Check ListView* ..................................................................................................... 50
    Check TwinList* ..................................................................................................... 50
    Table ListView* ..................................................................................................... 51
    Child Table ListView* ............................................................................................. 51
Database Window Test Mode ........................................................................................... 51
Advanced Formatting for Customer and Address Display Names** ................................ 52
Auto-Numbering Folder Creation ................................................................................... 52
Simplified Custom Table Field Links ............................................................................. 53
Friendly Field Prompts ................................................................................................... 54
Dynamic Image Generation (Reports)* .......................................................................... 54
Create a new layer without completing required fields* .................................................. 54
    Double-click Browser Queries to Execute* ............................................................. 55
3D .................................................................................................................................... 56
    Speed ........................................................................................................................ 56
    Automation................................................................................................................ 56
Extended 3D File Format Import Support** .................................................................... 56
Drag & Drop 3D Import ................................................................................................... 57
Improved Collada Export Support for Sketchfab .............................................................. 57
Zipped/Archived 3D Export* .......................................................... 58
3DX Library Update ................................................................. 58
3DxWare (SpaceMouse) Library Update ..................................... 58
Graphics .................................................................................. 58
Illustrator Workflow .................................................................. 59
Standalone Plug-in for Improved Adobe Illustrator File Exchange 59
Enterprise ................................................................................. 61
General ..................................................................................... 61
Auto-generated Enterprise Folders Enabled for Sync ............... 61
Improved Options for Opening Projects at Site Databases ....... 61
Coming Soon ............................................................................. 62
Overview

This document covers the new features introduced in Impact 2019 (internal build 11.0). Many of these features can be utilised out-of-the-box; however, several may require configuration changes, i.e., where an existing installation is to be upgraded. Such features are identified throughout this document by an asterisk (*). Certain features may have also been introduced towards the end of the Impact 2016 life-cycle, contained within patches or test builds. Such features are identified throughout this document by twin asterisks (**) . Not all the features described within this document are applicable to all Impact licenses. Please consult Arden Software for further details.
2D

Dimension Tools

One-click dimensioning (Both Ends option)

- A new Edit Bar option (Both Ends) has been added to the linear dimension tools (Dimension Horizontal, Dimension Vertical, Dimension Aligned & Dimension Rotated).

- When enabled, the option allows linear dimensions to be placed with fewer mouse clicks.
- As opposed to picking the start & end points for a linear dimension, and then setting projection line length via a 3rd mouse click, the new option simply requires a single click to identify an entity and a single click to specify the projection line length.
- The tool also works via click & drag – whereby a single click identifies the entity and the projection line length is set once the mouse button is released.

New “Dimension Arc Length” Tool/Entity Type

- A new Dimension tool/entity type has been added (Dimension Arc Length). As expected, the tool will allow the dimensioning of the length of an arc and the usual radial dimension options are applicable (Fixed Text, Text Mode, Text Width, Text Height, Dimension Setting).

- The tool simply requires you to pick the arc (to be dimensioned) and to specify the projection line length.
- The new tool may also be used when creating parametric dimensions (for resizable designs).
General Drafting and Editing

Construction Entity Consistency

- The behaviour for persisting the Construction entity option across tools has been modified:

- In Impact 2016 and earlier, activating the Construction option when running the Line Vertical tool (for example) would also activate the Construction option for the subsequent Line Horizontal tool use.
- In Impact 2019, all tools which make use of the Construction option will now persist the last-used value on a per-tool basis, and therefore not influence the behaviour of other tools.

Arrow key/cursor key nudges

- Over the last few Impact releases, the arrow/cursor keys (aka Nudge tools) have begun to control many basic tool options.

- The latest batch of tools to adopt this functionality include:

Drawing tools:

Multiple Lines & Arcs – in the Arc Start End Radius mode, the Nudge can be used to interactively modify the Radius value on the Edit Bar.

Line Axes - the Nudge can be used to interactively modify the Line Length value, on the Edit Bar.

Line Vertical & Line Horizontal - the Nudge can be used to interactively modify the Line Length value, on the Edit Bar.

Bisect 2 Points - the Nudge can be used to interactively modify the line length value, on the Edit Bar.
Line Angle Point - the **Nudge** can be used to interactively modify the Line Length value, on the Edit Bar.

Line Offset – when used interactively, the **Nudge** can be used to interactively modify the Fillet Radius value, on the Edit Bar.

Perpendicular Offset - the **Nudge** can be used to interactively modify the Line Length value, on the Edit Bar.

Line 2Point Offset – in non-interactive mode, the **Nudge** can be used to interactively modify the Offset Distance value (left/right arrows), and the Number of Offsets (up/down arrows) on the Edit Bar.

In interactive mode, the **Nudge** affects the Number of Offsets only.

Rectangle - the **Nudge** can be used to interactively modify the Width (left/right arrows) & Height (up/down arrows) values on the Edit Bar.

Polygon - the **Nudge** can be used to interactively modify the number of sides (for the polygon) and the diameter (of the polygon) the on the Edit Bar. The left/right arrows control the diameter, whilst the up/down arrows control the number of sides.

Circle 2 Points - the **Nudge** can be used to interactively modify the Radius value, on the Edit Bar.
Circle Radius Point Centre - the Nudge can be used to interactively modify the Radius value, on the Edit Bar.

Ellipse - the Nudge can be used to interactively modify the Width (left/right arrows) & Height (up/down arrows) distance values on the Edit Bar.

Dimension Tools:

Dimension tools - the Nudge can be used to interactively modify the width (left/right arrows) & height (up/down arrows) values of the Dimension Text on the Edit Bar. If a True Type/Open Font is used, the left/right arrows have no effect, as the text width is scaled proportionally to height.

Edit Tools:

Trim Fillet – in non-interactive mode, the Nudge can be used to interactively modify the Fillet Radius value, on the Edit Bar.

Trim Chamfer – in non-interactive mode, the Nudge can be used to interactively modify the Length 1 (left/right arrows) and Length 2 (up/down arrows) values, on the Edit Bar.

Trim Extend - the Nudge can be used to interactively modify the Extend Length value, on the Edit Bar.

Trim Splitup - the Nudge can be used to interactively modify the Number of Sections value, on the Edit Bar.

Transform Tools:
**Bend** – the **Nudge** can be used to interactively modify the **Bend Offset** value, on the **Edit Bar**.

![Bend Offset](image)

**Stretch Entity** – in non-interactive mode, **with no selection made**, the **Nudge** can be used to interactively modify the **X Offset** (left/right arrows) and **Y Offset** (up/down arrows) values on the **Edit Bar**.

![Stretch Entity](image)

In non-interactive mode, **with a selection made**, the **Nudge** can be used to interactively stretch entities the **entities**, modifying the **X Offset** (left/right arrows) and **Y Offset** (up/down arrows) values.

![Stretch Entity with Selection](image)

**Array Tools:**

**Array and Rectangular Array** – the **Nudge** can be used to interactively modify the **Number of Copies** that the array creates, on the **Edit Bar**.

![Array and Rectangular Array](image)

**Polar Array** - the **Nudge** can be used to interactively modify the **Number in R** value (left/right arrows) and **Number in A** value (up/down arrows), on the **Edit Bar**.

![Polar Array](image)

**General Nudge functionality:**

- **Significantly the Nudge functionality is no longer dependent upon the viewed orientation** (inside/outside or print-face/die-face). Using the **Select & Drag** tool as an example, a nudge via the **left arrow/cursor key** will move **selected** geometry from **right-to-left regardless of the viewed orientation**.
Note that certain caveats apply – such as the selected geometry being contained within a block, which may have been rotated....

- For an overview of the interactive concept, check the link here

New “To Layers” Tool

- New Block tool (Block>To Layers) has been added, to simplify the process of breaking apart single-layer drawings, containing multiple parts, into separate layers.

The tool is used to generate new drawing layers from blocks or from ‘flat’ geometry. The tool itself works on selected entities and presents Edit Bar options for the name & description for the new layer, plus a pulldown list for available layer settings:

- If a selection hasn’t been made prior to running the tool, the initial Help Tip on the Status Bar will prompt you to make a selection (by creating a marquee/selection box):

- Once a selection has been made, the new layer will be created automatically, in accordance with the Edit Bar options, with no further action required.
- If a selection has been made prior to running the tool, the new layer will be created in accordance with the Edit Bar options once the OK button has been activated.
- Note that the marquee/selection box uses the directional functionality found in tools such as Select & Drag, Select Lasso & Edit Delete - a left-to-right marquee/selection box will select entities touched by or completely inside the marquee, whereas a right-to-left marquee only selects entities which are completely inside the marquee/selection box.
- The tool differs from the existing Block>Blocks to Layers tool in that it requires entities to be selected
and can create new layers from flat geometry as well as Blocks.

- Note that the tool will repeat (like most other Impact tools), so avoid creating unnecessary/accidental drawing layers, ensure that you cancel the tool once you have finished creating new layers!

**New Layer “Quick Duplicate” Tool**

- A new Edit tool (Block>Duplicate Current Layer) allows the quick duplication of the current drawing layer.
- Many users make use of the Copy Layer functionality for this purpose – but the dialog that’s displayed prompts you to copy any layer from any open project. This process can be quite long-winded if you only wish to copy the current drawing layer.
- The new tool requires no user input and displays no dialog boxes – it simply makes a copy of the current drawing layer – providing a significant time-saving.
- The tool is available via the Block menu:

  ![Block menu](image)

- Via the Drawings Hierarchy tab of the Impact Explorer:

  ![Impact Explorer](image)

- Via the Layer Tabs:
Via the Design Options (Options>Project>Layers):

And, via a user-definable hot-key. Note that the tool is listed within the Edit Tools category):

In operation, the tool duplicates the current layer (and associated database information) and adds a _1 suffix to the layer name.
Entity Highlighter Improvements*

- Users now have greater control over when and how highlighters are applied to different draw and edit operations.
- The Highlighting & Tool Selection Marker functions have now been separated, in order to allow users to enable/disable Highlighting & Tool Selection Markers as required.
- To clarify the difference between Highlighting & Tool Selection Markers, consider the first click of a TrimFillet operation. With both options disabled, the following would be displayed:

- With Highlighting enabled, the following would be displayed (the first entity would receive the user-defined Highlight colour):

- With the Tool Selection Markers enabled, the following would be displayed (the first entity would receive the user-defined Tool Selection Marker colour):

- Within Options>Environment>Display, you’ll now find toggles for both options:
• For users wishing to configure Impact to resemble Impact 2015 & earlier, simply disable both options.

• The functions may now be toggled via user-definable keyboard shortcuts/hot-keys. Follow Options>Environment>Environment>Keyboard (or Customise Mode>Keyboard) and look for the Options Tools category:

![Impact Options dialog box showing keyboard shortcuts]

- You can configure the toggles for Highlighter and Tool Selection Makers as you would any other hot-key.

- Additionally, visual confirmation of the status of either function is provided by optional icons which may be added to a toolbar (such as the General Toolbox):
• The screenshot on the left shows **Highlighting enabled** and **Tool Selection Markers disabled**, whilst the screenshot on the right shows the inverse.

**New “Snap Cursors” Indicators**

• To aid with accurate snapping during draw and edit operations Impact can now offer coloured-coded indicators on the cursor which reflect the type of snap being made, before you even click. This feature is enabled by default on upgrade.

• Here we see the snapping cursor feedback in action, indicating (from left to right), Mid, Quadrant and End snap modes.
• The size and colour of the cursors to indicate the various snap modes can be customised (see Options > Environment > Environment > Cursors) and either be a solid fill (default) or outline only display option, and you can customise the colours as required (see Options > Environment > Environment > Colours).
• The default colours are as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Database</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap Cursor - Block Insert</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Bridge End</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Bridge Mid</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Centre</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - End</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Entity</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Grid</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Intersection</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Mid</td>
<td></td>
</tr>
<tr>
<td>Snap Cursor - Quadrant</td>
<td></td>
</tr>
</tbody>
</table>

Palettes*
• New Rule Type (Cascade) has been added, with the following configurable properties:
- **Step Offset** – the distance between each entity.
- **Length** – the length of each entity.
- **Angle** – the angle of the entities relative to the centre line.
- **Side** - the side of the centre line to which the entities will be offset (left or right).
- **Side Offset** – the distance that the entities should be offset from the centre line.

**Palette Text** can now have an alternative palette (note that palettes may be edited within a drawing, within a template or within the Master Template, via **Design Options>Palettes**):

- This allows palette text to be output in a non-manufacturing palette, for example.
**General**

**Multi-page PDF Export***

- It’s now possible to create multi-page PDF exports – allowing you to export multiple layers from a single project into a single PDF document. This also allows you to output multi-page report templates into a single PDF document (these developments are also compatible with the BOM (Bill of Materials) developments).
- A new option has been added to the General Export tab of the Export Master Tool Settings: (Export multiple layers to a single file if supported (non-Impact formats only)):

![Import/Export Settings](image)

- As a result, it’s possible to generate a multi-page PDF document from a multi-layer Impact project, like the following (note that Adobe Reader’s Page Thumbnails option was used to display the thumbnails):
• The following PDF was generated from a multi-page Report Template (again, Adobe Reader’s Page Thumbnails option was deployed to display the thumbnails):

![Multi-page PDF example]

• **Currently** this option applies **solely** to the Adobe PDF format. *The option was added to the General Export tab (as opposed to the Adobe PDF node) to allow multi-page support for any future formats supporting multiple pages.*

• Note that the page names displayed in Adobe Reader are numerical – it’s not possible to replace these labels with Impact layer names.

• Note also that if you are using an export filter which creates PDF Layers for each exported palette, you’ll create several instances of palettes which are common to each layer (e.g. Cut, Crease etc).

• **Layers** within the visible page will always be listed in **bold type** within Adobe Reader’s Layer list.

• In the following screenshot, the **Dimension, Cut & Crease** palettes are contained within the visible page:

![Layer list example]
• In the following screenshot, **Dimension, Sheet Size, Stock Sheet, Cut, Crease & Text** palettes are contained within the *visible page*:

![Screenshot of palettes](image)

• **Adobe Reader** also provides an option to show layers only for the *Visible Page(s)*:

![Layer options in Adobe Reader](image)
As expected, this would present the following:
PDF Export to Respect Drawing Order (for better CutCrease export support)*

- To aid the export of CutCrease lines to the PDF format, a new option has been added to the Adobe PDF branch of the Export Master Tool Settings:

![Image of Import/Export Settings dialog]

- The Drawing Order can be defined on a Project, Template or Master Template level via Options>Project>Palettes>Drawing Order, and allows palettes to be displayed in front of/above other palettes when they overlap:

![Image of Design Options]

- In the above example, the Cut palettes would be ‘drawn’ after the Crease palette. Therefore, exporting a drawing to the PDF format, respecting drawing order would guarantee that a CutCrease line, (where the Crease palette is configured not to explode into segments) would export to the PDF format as shown below:
• In contrast, exporting palettes using the following drawing order:

• Would result in:
Multi-Face Export*

- It’s now possible to export both faces of a 2D drawing layer, with a single export action (which compliments the improved multi-page PDF export support).
- A new option (Export both faces) has been added to the Non-native branch of the Export node of an Import/Export Master Tool Setting:

![Export Settings](image)

- If the file format doesn’t support multiple layers in a single file, enabling this option would generate one file, per face.
- For applicable formats (such as Adobe PDF), enabling this option would allow you to generate a single file, containing both faces of a drawing layer.

PDF Library Update

- Routine update to the latest version of the 3rd party Datalogics PDF library.

DWG Library Update

- Routine update to the 3rd party Open Design Alliance DWG library.
- Impact 2019 is now able to import version 2018 of the DWG and DXF file formats.

Support for DDES3 (CGATS/SC6/WG3) IT8.6 Revision Import

- Impact 2019 supports the import of DDES 3.1 files
Drag and drop from Outlook (or file locations)

- Drag & drop support (from Outlook & file locations) has been significantly improved. In most cases, it is now possible to drag multiple files or a single Outlook message into Impact, without needing to first save the attachment, the message or the Impact project.
  
- Single or multiple vector-based files may be dragged from the desktop (or any file location) onto an Impact canvas and the Import dialog will be displayed for each file.

  ![Drag and drop support](image1.png)

- Multiple files (of any format) can be dragged from the desktop (or any file location) onto the Project Documents or Customer Documents window, and the Add Documents window will be displayed.

  ![Multiple file drag](image2.png)
• Single Outlook messages (and individual files contained in an Outlook message) can be dragged onto the Project Documents window or Customer Documents window and the Add Documents window will be displayed:

• Drag & drop support is also available via the Projects Browser (and by extension, the stand-alone Impact Viewer). Observing the same rules as above, files & messages may be added to the Project Documents and Customer Documents windows.
• When adding a **zipped** file to the document management system, Impact will offer the choice of adding the **zipped** file itself or **unzipping & attaching the contents** of the zip archive:

![Add Documents to Project](image1.png)

**Licensing/Nalpeiron V10***

• Updates to software-based **Nalpeiron** licensing make for simplified setup and maintenance.
• Significantly, this removes the need for a **locally installed Nalpeiron** Licensing Service and brings a new heartbeat/phone-home method, allowing silent and automatic update of licences, without the need to **manually deactivate and reactivate**.
• Licences may be subsequently **deactivated** via the **Login** screen as there’s no longer an installed local **Nalpeiron** service:

![Login screen](image2.png)

![Impact Options](image3.png)
• One additional benefit of the updated licensing method is that licence codes are stored locally, and may be accessed from a pull-down list (if you’re in the habit of activating & deactivating licences to switch them between workstations):

• Enhanced licence logging options are also available:

• As expected, an offline activation mode is also available.
Licensing/Dongleless Licence Server*  
- Due to the increasing number of requests to host Impact licensing services in virtualised environments, the Impact (and nServer) license server services now support dongleless operation. This removes any reliance upon physical hardware/DK2 dongles.  
- Note that unlike the hardware/dk2 licence server, the dongleless licence server may not be transferred to another host workstation/server without Arden Software involvement. A machine-specific enabling file is needed – and if the licence server host is changed, a new enabling file needs to be generated by Arden Software.

Script Security Modifications*  
- The security options for VB Scripts & IML Macros have been moved from Workstation>Security to Options>Environment>Database Installation>Security:  

- This change allows the options to be specified per database, as opposed to per workstation, thus simplifying the deployment process for anyone wishing to use script (and IML) security.  
- In addition, a new option has been added to provide script security for nServer.
Parametrics & Standards*

- It’s now possible to suppress the “Delete Parametric Dimensions?” prompt, when running Standards:

  ![Geometry Creation](image)

- Users may forget to delete the parametric dimensions (or switch them on accidentally) - and this may lead to parametric dimensions becoming visible within the drawing itself or within subsequent Reports.
- A new privilege (“Allow Retaining Parametric Dimensions”) has been added within the Standards node of the User Privileges Master Tool Setting:

  ![User Privileges](image)

- If enabled (note that this is the default option, post-upgrade), the “Delete Parametric Dimensions?” option will be visible within the Geometry Creation page of the Standard Wizard.
- If disabled, the “Delete Parametric Dimensions?” prompt will not be displayed to the user and parametric dimensions will not be added to the drawing:

  ![Geometry Creation](image)
Memory Handling Improvements - Large-Address Aware (LAA)

- 32-bit applications (such as Impact) can only access 2GB of RAM - even on a 64-bit OS, with lots of available RAM.
- Under a 64-bit OS, it’s now possible to allocate an increased amount of RAM, and to take advantage of this, Impact (and the Impact Viewer) **2019** will install a **3GB** shortcut:

![Impact 2019 and 3GB shortcut](image)

- The 3GB shortcuts will then allow Impact (and the Impact Viewer) to run with access to increased RAM.
- This should be beneficial when importing large 3D models with a high polygon count.

Document Relationships for Symbols and Templates*

- You can now also associate documents with symbols and templates. Typically, you might use this to directly store related reference material or part specifications.
- This feature then offers convenient access to those documents when adding or using symbols and templates.

![Symbol Reference](image)

- As a reminder, this change builds on Impact’s existing support of a wide range of document relationships which offers the ability to associate documents with objects, including:
  - Project Documents
  - Customer Documents
  - User Documents
  - (Document to) Other Documents
  - Layer Documents
  - Contact Documents
  - Site Documents
  - Address Documents
Manufacturing

Stripper Tool Performance Improvements
- Performance improvements have been made when placing restrictions and male stripping parts (notably within an internal waste area that has replicated instances).
- Speed improvements have also been made when working within a zoomed view on a stripped waste area.

Plotter Optimisation*
- Significant improvements have been made regarding the optimisation of machine output.
- Advanced Optimisation options have been added to the Post Processor setup:

  ![Plotter Optimisation Options](image)

  - **Quick** – provides a quicker optimisation by finding a compromise between the actual running-time of the optimisation algorithm and the quality of the optimisation. Typically, this option would be used for outputting a Dieboard or a drawing with many entities (e.g. 7,000 entities or greater).

  - **Full** – provides better optimisation by reducing the amount of rapid travel in the final plot. This option also disables the Optimise output for internal cuts option. A drawing containing a lower number of entities, distributed evenly over a drawing layer may be considered suitable for Full optimisation.

- During internal testing, we found that the Quick Optimisation option gave the following reductions in Rapid Travel distances for an entire layer compared to the current output:
  - Layout of Samples 22.71%
  - Dieboard 14.49%
  - Female Stripper 9.44%
  - Routing Stripper 14.19%

- Similarly, we found that the Full Optimisation option yielded the following reductions (again, for an entire layer, compared to the current output):
  - Layout of Samples 28.96%
  - Dieboard 17.26%
  - Female Stripper 10.49%
  - Routing Stripper 15.05%

- Note that results will vary, based upon drawing complexity & hardware specification.
Symbol Position Reference When Plotting*

- Several machines reference the centreline notch (for location) and as the 0,0/origin point. Impact 2019 can set the origin of output relative to the insertion point of a defined symbol. This is useful, as sometimes the centreline notch is offset from the actual centre of the drawing.

![Diagram showing symbol placement options](image-url)
Automatic Creation of Symbol Patterns and Alternative Symbols

- The Block Create Symbol Pattern tool allows the creation of a symbol pattern from an Impact drawing. The Create Symbol Pattern dialog now has the option to set a ‘check boundary for interference’ symbol against each individual symbol.
- The collision symbol is a requirement - for the mounting holes for the Rotary Dieboard tool, for an example.

Blanker Frame Symbols Ordering*

- The Blanker tool has the option to allow the manual placement of symbols, relative to the lower frame. The order in which these symbols are presented to user can now be predefined, resulting in easier grouping:
Rotary Dieboard Workflow Improvements

- To improve the workflow of the Add Rotary Dieboard tool, keyboard shortcuts/hotkeys can be defined for the various sub-tools:
Diemaking Auto Tasks and Value Mappings*

- There are two new auto tasks - Diemaking Tool (Before) and Diemaking Tool (After):

- These tasks will apply to all Diemaking tools which currently have individual auto task capabilities.
- There are also two new Value Mapping triggers that can be used to copy values into variables before (or after) many Diemaking tools are run:

- This provides a single trigger that all Diemaking tools will use, rather than the specific triggers. For example, the Diemaking Tool (Before) value mapping trigger can be used to map a database source to a variables destination – and the variables could then be picked up by the Add Dieboard tools...
User Interface

**Screentips for Enhanced Project Previews** *

- Screentips/pop-up hints have now been added to provide custom project details and thumbnail previews in the History and Working Projects lists.
- They are also visible within the File > Open Project dialog.
- The lists will display a thumbnail image (provided one has been created) and an appropriate header & footer for each item type (Project, Symbol or Template), when hovering over a list item:

  - Whilst default configurations will be provided for each item type, there’s scope for customisation via the Show Screentips options (Options>Environment>Database Operation>History lists):
Information may also be displayed from layer type tables – so the following tip configuration:

**DRAWINGS**

[D_NAME]
[D_DESCRPT]
Customer: [D_CUSTOMER]
Folder: [D_GROUP]

**ONE_UP**

Layer: [LAYERS.NAME], LxWxD: [LENGTH] x [WIDTH] x [HEIGHT]

**MULTI_UP**

Layer: [LAYERS.NAME], Width & Height: [SHT_WIDTH] x [SHT_HEIGHT], % Utilisation: [UTIL_PCN], % Waste: [WASTE_PCN]
• Would display the following screen-tip:

Enhanced ‘Open Project’ dialog, including custom field lookup

• Previously, by default, the ‘Open Project’ dialog allowed searching on Project Code, Reference, Description (or any other integer or character-type fields which were not hidden or private).
• The dialog has now been expanded to allow searching of fields within the DRAWINGS, LAYERS and Layer EXTRA (typically One_Up/Multi_Up) tables, and includes and integer or memo-type fields (such as Project Notes):
• Impact also uses field Prompts instead of field names for friendlier and more descriptive items in the dropdown list.

• As expected, these options may be set a user or a user-group level.

• Note that a simple filter has been added to allow Standards to be omitted from search results:

• The additional fields will lead to quicker drawing/layer finding.
Icons for Visibility Toggles

- The Visibility Toggles have been updated by the addition of tool icons:
Database

Impact 2019 introduces the largest collection of new database features and enhancements in a single version since the inception of the product. These features span different categories and allow for better organising, searching and the presentation of data within the Impact database.

Many-to-many*

- This powerful new feature is a huge topic, requiring its own documentation (available separately). Essentially this adds support for extended, custom database table relationships, e.g. multiple customer and contact addresses for ship to, billing, or as in the below diagram of a table relationship, a way to assign multiple ink colours for a design.

Here’s an example of how that may then be presented to a user for selection in an Impact Database Window, making use of one of the new Check ListBox field control type, as covered later in this document.
Database Structure (DBS)

- There are several new database structure changes (tables/fields/indexes, etc.) that have been added to Impact 2019.
- The structure changes dialog has had a makeover, including the features:
  - It now uses a hierarchy tree to display all structure changes
  - Added icons for different change types
  - Added more details including showing column types and lengths
  - Added detected table relationships changes.
  - Added context menu for checking various tables/columns/relationships quickly.
**Non-enforced Null Changes**

- There is a new mechanism within Impact to detect if a user has changed a column's required (nullable) flag so it is not automatically reset at next upgrade.
- For example, if you configure the ONE_UP.LENGTH to be required (non-nullable) then when updating Impact, this has traditionally always forced back to not required (nullable).
- For each column that should NOT have its nullable flag reset you simply need to configure the ‘Do not enforce when updating database’ checkbox.

- This option only applies when configured in an exported DBS file that is subsequently imported into an existing database. This means that any upgrade of Impact will not reset these nullable flags.
- These changes have already been applied to all appropriate columns in the ipds_dbb.dbs file we distribute. No configuration changes are required at any central or site databases.

**Archived or Active Items for Dynamic Lookups**

- Impact 2019 introduces a mechanism to archive items within a dynamic lookup. Often, the items that are contained within a dynamic lookup become superseded with new items. For example, say you have a table of manufacturers joints and originally had a 'glued' option. You now wish to change terminology and extend it to use 'Glued inside' and 'Glued outside' instead. If you open an old project that used the original option, you still want to be able to see this. However, if you were to create a new project, you don't want to be able to see/choose the old option. This was not possible in Impact versions prior to Impact 2019.
- You can now choose to either configure either an Active or Archived column depending on your specific requirements and terminology that you wish to use.

**Table Display Names/Prompts**

- A new ‘Display Name’ property has been added for each table in the Table Structure form
- This is now used to display friendly table names in the following situations:
  - When Impact prompts to delete tables
  - When listing fields to include in the Open Project searcher’s field selection
  - When displaying fields to select by table for building Advanced Database Queries
- During upgrade existing database tables are automatically updated and the ‘Display Name’ is copied from the ‘Menu Text’
Translatable Table and Column Prompts*

- For the convenience of users connected to the same database as users of a different language, you can now localise the table and column names displayed throughout Impact.
- In the below example, we see a selection of key table and column prompts translated to German. The same translations will appear in the File > Open > Project dialog.

Layer List Sorting

- The Database Window for Projects, which is commonly enabled in the Database tab of the Impact Explorer and also accessible via Database > Project menu, contains entries for accessing "Project Information", "Customer Information", plus a list of all the project's layers for easy selection. It’s not unknown for this to contain a large number of layers, which until now have not been presented in a particularly useful order. This list is now sorted alphabetically, allowing users to quickly locate and switch between them for view or edit.
- A comparison of Impact 2016 (left) and 2019 (right) is presented below:
Improved Customer Selector and Customer Group handling*

- Supporting searching and selecting customers by customer group, address and other common customer attributes, as well as the flagging of **Favourite Customers**:

- The customer list display may now be managed in the same way as the Details pane within the Projects
Browser (and the Revisions pane within the Browser Information pane), via **Customer Options** (subject to user privileges):

- Note that the existing ‘**Group customers by first letter**’ option has been **moved** from the **Database Operation->Dialogs** page:

  .... into the **Browser Options** form (as it only applies when using the **Impact Browser**):
Bill of Materials (BOM)*

- With the promise of component part lists, and a reporting tool with multi-page output (PDF), this feature is made possible by the core ‘Many to Many’ database improvements introduced in to this product release, for which there are many similar applications. The BOM feature will however be delivered as a comprehensive plug-in due for release later in 2019.
- Please feel free to register your interest in this forthcoming feature to be notified when it becomes available.

New Project ‘Open Copy’ Action

- New dedicated ‘Open Copy’ option has been added to the context menu in the Project Browser – allowing you to open a ‘Copy’ of a project immediately, as opposed to using the ‘Open a copy of the selected project….’ option from the Open Project dialog.

Enhanced Database Windows*

With the addition of user-defined table relationships, there are several new concepts and features to introduce regarding Database Windows. The highlights of which are included here:

Control Type Icons

DBW Control Types now have iconography to better distinguish controls from one another. These icons appear when adding a control type in the Field Attributes dialog, as well as the Fields tab of the DBW MTS.
**New Control Types**

Six new DBW Control Types have been added:

- **Picture**: A new control for editing images.
- **Check Listbox**: A drop-down combo presenting a list of checkable items.
- **Check ListView**: A list view control presenting a list of checkable items.
- **Check Twin List**: A twin list view control presenting two lists of items that can be moved between the lists.
- **Table ListView**: Used to display multiple table records in a grid view directly in a DBW. Typically, this is the only control in the DBW.
- **Child Table ListView**: Used to add/edit/delete multiple child table records directly in a DBW.

**Picture Control**

- A new Picture Control has been added to DBW's for adding images to the database. The picture control can read/write images to Picture (BLOB) columns in a database table.
Check Listbox*

- The Check Listbox is a drop-down list box with a checkbox included with each entry item. This allows for selection of multiple values within one control, while the dropdown list box occupies very little screen real estate.

![Ink Colors](image)

Check ListView*

- The Check ListView is a static list view with a checkbox included with each entry item. Like the Check Listbox, this allows for selection of multiple values within one compact control.

![Ink Colors](image)

Check TwinList*

- The Check TwinList is a two-column control with arrows to move items between columns. Items in the left column indicate all available choices, while items in the right column are the assigned/chosen values. This allows for selection of multiple values within one control.

![Ink Colors](image)
Table ListView*

- The Table ListView control is used to create a specific type of DBW for displaying multiple records from the same table within a DBW. Commonly referred to as a ‘ListView DBW’. The ListView DBW is only appropriate when directly editing tables within the database.

Child Table ListView*

- The Child Table ListView control displays an embedded listview control for child records related to the current parent record display in the DBW.

Database Window Test Mode

- When configuring database windows (DBW) you can use the Test button to see a preview of how the DBW will look. This helps with field arrangement.
- In Impact 2019, the Test button has been improved to make it easier and more efficient to configure and test dynamic data within DBW’s without the need to save the MTS and use it within Impact.
- The DBW test mode now also loads dynamic lookup values and will react to child/parent filtering if possible. If your DBW includes dynamic lookups that are filtered on D_CUSTOMER then it will use the customer from the current drawing or the default customer.
- The DBW test mode allows full interaction with Child Table List Views, including allowing you to add/edit/delete rows from the ListView controls. **No data is updated when using Test mode.**
Advanced Formatting for Customer and Address Display Names**

- You can now append/prepend additional identifying data within customer and address selectors, to clearly distinguish records based on a combination of key fields. For example, you may wish to configure your display settings to include a customer’s city or state in their display name.

Auto-Numbering Folder Creation

- Project save folders can be created automatically (if they don’t already exist) as part of an auto-numbering master tool setting.
- This is very useful if you currently organise your projects by month or quarter for example, and are therefore routinely creating new folders manually.
Simplified Custom Table Field Links

- Previously, it was difficult to remember the syntax needed to access data from parent tables (typically when wishing to display lookup values in report templates). With any dynamic lookups that are created or updated to use the new table relationships feature, you now have a convenient way to locate and display values from linked fields.
Friendly Field Prompts

- A new text editor option offers a toggle button labelled ‘Aa’ to switch between a field’s name and its more easily recognisable field prompt:

- This option replaces the actual database column name with the user-defined prompt (or text-label) – which usually has a more meaningful description, to aid understanding.

Dynamic Image Generation (Reports)*

- Images stored in picture type database fields or images from disk can now be added dynamically to report templates. For example, you may wish to include your customer's logo or the designer's avatar on a report.

- These images are controlled by adding a text entity with a special format, some examples of which include:

  o `[ImageFile("[Script("<VBScript>Result = "D:\image1.jpg"")])"]` - Loads an image directly from disk
  o `[CUSTOMER.CS_PICT]` - Loads an image from a picture type field in the CUSTOMER table
  o `[ImageFile("[CUSTOMER.CS_FILE]")]` - Loads an image based on a file path held in the CUSTOMER table

Create a new layer without completing required fields*

- No longer prompting users to populate required database windows fields until save time
Double-click Browser Queries to Execute*

- There is now an option to define the behaviour when you double-click on Query from within the Impact Browser.
- This often-requested option can be found under **Options > Environment > Database Operation > Dialogs** and click the **Browser Options** button.
- Double-clicking a Query can be set to one of the following:
  - **Shows Properties** (behaviour in Impact 2016 and earlier)
  - **Executes Search** (new in 2019)
3D

**Speed**
- Faster model creation and better handling of multiple copies of the same model, for example, as produced by 3D arrays, resulting in a smaller memory footprint and more responsive working environment.

**Automation**
- There’s now the possibility to create and update 3D models via Impact COM (or nServer), to support automation or external 3D model generation requests, e.g. for web-to-pack solutions
- This includes the independent update of materials, geometry, board and artwork.

**Extended 3D File Format Import Support**
- The import of 3D file formats *Wavefront (.OBJ)*, *Stanford Triangle Format (.PLY)* and *Stereo Lithography (.STL)* are now supported, including textures, without the need for the 3DX library add-on:

![Supported Formats]

- Remember to update your 3D Import Master Tool Settings to enable the new formats:

![Import / Export Settings]

- **No additional settings are needed for these formats** – there’s nothing else to configure other than enabling the formats within your 3D Import MTS.
Drag and Drop 3D Import
• 3D objects may now be imported via drag and drop, for quicker/easier import.
• Simply drag the objects onto the Impact application:

• The 3D Import Master Tool Settings will be displayed for each dragged object.
• This allows you import the objects(s) into the current 3D layer, into a new layer in the current project or into new project(s).

Improved Collada Export Support for Sketchfab
• Bump-mapping (embossing/debossing) and metal texture support for Collada exports (to the Sketchfab service) has been added:
Zipped/Archived 3D Export*

- For file size reduction, and easier distribution of 3D exports that produce multiple files, we’ve added an archive option to the 3D Export Master Tool Settings where applicable.
- The option will compress the output of a 3D model and any accompanying textures into a single zip file, allowing quicker & easier sharing (email, uploads etc) of 3D content.
- The new option is applicable to 3D Studio Binary (*.3ds), AutoCAD Drawing (*.dwg), COLLADA (*.dae), VRML 1.0 (*.vrml) and VRML 2.0 (*.wrl) formats

- This functionality is also supported by the COM interface.

3DX Library Update

- This update adds or extends support for the following 3D file formats (including the usual bug-fixes):

  Acis 2018 (R28)
  Catia V5 V5_6R2018
  Creo 4.0
  Inventor 2018
  NX 12
  Parasolid v30.1
  SolidWorks 2018
  SolidEdge ST10
  Rhino 6

3DxWare (SpaceMouse) Library Update

- The SpaceMouse library has received a routine update.
Graphics

Illustrator Workflow
Standalone Plug-in for Improved Adobe Illustrator File Exchange

- A plug-in for Adobe Illustrator for Mac and PC has been developed.
- The plugin is currently compatible with Adobe Illustrator Version 17 (CC 2015.5), 18 (CC 2017) & 19.
- The plug-in provides improved layer support (automatic creation of PDF layers corresponding to Impact palette names); automatic artboard resizing (to the design extents) and locking of dielines for Impact-created PDF files, exported from Impact 2010 & later.
- The plug-in searches within a PDF file for the pdf:Producer>Impact< tag. If this is found, the PDF file is assumed to be an Impact-generated PDF:

![Adobe Illustrator](image1)

- The PDF is then is processed in accordance with the plug-in preferences - which are configured within Adobe Illustrator itself (via the Window>Arden Software menu):

![Impact CAD Preferences](image2)
• A dedicated help page has been created for the ‘Impact Plug-in for Adobe® Illustrator®’ which can be found here: https://help.ardensoftware.com/impactpluginforillustrator_1_en/

• Note, further Adobe Illustrator plug-ins are now being developed to deliver, amongst other features, live 2D/3D preview of graphics as edited and saved within Illustrator.
Enterprise

General

Auto-generated Enterprise Folders Enabled for Sync

- Folders created automatically as the result of projects being synchronised between Enterprise databases now have their ‘Synchronise to Enterprise’ flags set automatically, meaning any additional contents added to that folder will also be synchronised.

- Typically, database administrators will manage the folder structure within the central database and publish it, including configuring which of those folders should be synchronised back to central. However, automatically created folders or those added by individual users may not have had this flag set, this this feature becomes useful.

Improved Options for Opening Projects at Site Databases

- Force local only OR central only project check-outs. Simplifies the check-out process, preventing accidental collision of changes or working on outdated versions of a project.
Coming Soon
Look out for the following Enterprise features, which will be delivered in a soon-to-be-released Impact 2019 Service Pack:

Master Project Support
- Folders renaming is now fully supported for synchronised folders

Master Project Support
- Master Projects is an advanced Impact feature that allows commonly used design components (layers) to be inserted and later automatically updated where featured in other projects in a database. This feature will also be supported across a wider Enterprise system, combining these two powerful concepts for ultimate flexibility.

Linked Revisions Support
- Unlike making a copy of a project, linked revisions help you track the ancestry of a project and projects derived from it. This feature will also be supported across a wider Enterprise system.